L3SWによるVLANルーティングの設定

前回考え方についてまとめたので、今回は実際に設定をしてみる。 実際にL3SWでVLANルーティングを行うための設定を行うためには, それぞれのレイヤ間をつなぐ設定が必要になる.

  • レイヤ1: 物理ポート
  • レイヤ2: VLAN
  • レイヤ3: 内部ルータ

初期状態

レイヤ1 - レイヤ2間
まずは物理ポートとVLANの結びつけ. これはL2SWでも行ったとおりである. Fa(FastEthernet)0/1と0/2をVLAN1, Fa0/4をVLAN2に設定してみる. 初期状態ではVLAN1しかないため,VLAN2を作成する.

Switch#configure terminal
Switch(config)#vlan 2 
Switch(config)#interface Fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#exit
Switch(config)#interface Fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 1
Switch(config-if)#exit
Switch(config)#interface Fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit

ポートへVLAN割り当て

レイヤ2 - レイヤ3間
VLANと内部ルータを結び付けるため,内部ルータにSVIという仮装ポートを作成する. 作成すると自動的にVLANと結びつけられる. SVIは作成時点ではshutdown状態なので,no shutdownを忘れずに.

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.254 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.2.254 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit

SVIを作成

レイヤ1 - レイヤ3間の接続
場合によってはVLANを割り当てず,直接内部ルータに結びつけても良い. この場合ポートはスイッチのポートでは無く,ルータのポートとして振る舞う. 今回はFa0/3を設定してみる.

Switch(config)#interface Fa0/3
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.3.1 255.255.255.0

ルーテッドポート作成

レイヤ3の設定 ip routingコマンドを打ち込み,ルーティングを開始する

Switch(config)#interface vlan 1

以上の設定でVLAN間ルーティングを行うことができる.

Written on December 17, 2011